Объявление

Хотите приглашение на сайт? Пишите: niikto@samovarchik.info


 

Как начать работать с RouterOS

Для начала работы с MikroTik RouterOS в Windows необходимо приложение "Winbox", его можно скачать из памяти роутера, через любой имеющийся браузер, указав в адресной строке http://ip-адрес устройства/
(также по адресу доступен веб-интерфейс и мануалы)

Если адрес устройства заведомо не известен берем "Winbox" в интернете по ссылке

Winbox поможет определить ip-адрес устройства. Нажимаем "..." приложение найдет устройство в какой бы подсети оно не находилось, в раскрывающемся списке выбираем устройство.

скриншот

download.php?id=630

Вводим логин и пароль.
(если не знаем логина и пароля то смотрим как сбросить аппаратно на вики http://wiki.mikrotik.com/wiki/Manual:Password_reset для программного сброса заходим в веб интерфейс http://адрес устройства, вкладка System -> RESET! и задаем ip-адрес устройства и маску ввода которые будут после сброса на дефолт.) 

Объединение локальных сетей по средствам Wi-Fi на RouterBoard 411u

Открываем Winbox выбираем устройство, вводим логи и пароль. В меню слева выбираем пункт "Interface", переходим в окно Interface list, на первой вкладке interface приведен список доступных интерфейсов, по двойному клику на любой из них можно производить их настройку, "+" или "-" удалит/добавить, у каждого интерфейса есть атрибут "type", он обозначает тип интерфейса.

скриншот

download.php?id=631

Для настройки Wi-Fi двойным кликом выбираем интерфейс с типом wireless(я задал ему имя wlan), в окне настройки первым делом нажать Advanced mode, это расширенный режим настройки, после изменений в настройках каждой вкладки нажать Apply чтобы применить изменения.

Для совместной работы двух и более сетей одно из устройств должно работать в режиме "bridge", а второе и последующее в режиме "station wds"

схема

download.php?id=635

настройка устройства в режиме работы bridge

Настройка устройства в режиме работы "bridge"

Interface->wlan->wireless->
mode: bridge
band: 2.4Ghz-B
frequency: 2412
SSID: MikroTik
( может быть любой, но на station ws и bridge они должны совпадать)
Security profile: default
Antenna mode: a
Default authinticate: да
Default forward: да
Hide SSID: нет

Interface->wlan->WDS
WDS mode: dynamic mesh
WDS default bridge: bridge1
WDS default cost: 100
WDS cost range: 50-100

Interface->wlan->Nstreme
Enable nstreme да
Enable polling да
Disable CSMA да
Framer policy: none
Framer limit: 3200

Interface->wlan->Data Rates->
default ставим отметку


Bridge->Bridge
Создать новый(плюсик)->ок (по умолчанию bridge1)
Bridge->Ports
Добавляем wlan и lan подключения, в свойствах каждого поставить
bridge: bridge1 чтобы объеденить эти интерфейсы.

IP-адрес по умолчанию будет задан интерфейсу ether1, его нужно перезадать на bridge1, идем в
IP->adresses
изменяем

настройка устройства в режиме работы station wds

настройка устройства в режиме работы "station wds"

Interface->wlan->wireless->
mode: station wds
band: 2.4Ghz-B
frequency: 2412
SSID: MikroTik
( может быть любой, но на station ws и bridge они должны совпадать)
Security profile: default
Antenna mode: a
Default authinticate: да
Default forward: да
Frequency mode: manual txpower
Country: no country set
Antenna Mode: antenna a
Antenna Gain: 0
DFS Mode: none
Proprietary Extansions: post-2.9.25
WMM support: disable

Interface->wlan->Data Rates-> default ставим отметку

Interface->wlan->WDS
WDS mode: dynamic
WDS default bridge: bridge1
WDS default cost: 100
WDS cost range: 50-100

Interface->wlan->Nstreme
Enable nstreme да

IP-адрес по умолчанию будет задан интерфейсу ether1, его нужно перезадать на bridge1, идем в
IP->adresses
изменяем

Bridge->Bridge
Создать новый(плюсик)->ок (по умолчанию bridge1)
Bridge->Ports
Добавляем wlan и lan подключения, в свойствах каждого поставить
bridge: bridge1 чтобы объеденить эти интерфейсы.

В моем случае для организации Wi-Fi соединения использовались две направленные антенны D-Link ANT24-1201 поэтому, частоту  свыше 2.4Ghz было использовать бессмысленно( особенность антенны).

Стандарт "B" был выбран, по причине более высокой стабильность по отношению к стандарту "G" и "turbo-G"(~50 потерь из 15000 пакетов)

Редактировался viktor (22.01.2012, 02:10:32)

http://www.mikrotik.ru/files/instrukcii … e-mikrotik документация по настройке
бэкап конфигурационного файла делается так:
Winbox->Files->backup
Восстановить настройки из файла
Winbox->Files->Restore
Можно сохранить бекап на жестком диске, скопировав в буфер бекап файл кнопкой Copy

http://mikrotik.axiom-pro.ru/library.php много инфы по настройке

Редактировался viktor (22.01.2012, 01:59:52)

Phantom пишет

для балансировки 2х каналов в микротике, необходимо создать оба подключения (OMKC-pppoe, Enforta-Static IP), прописать роуты для обоих подключений и добавить DNS обоих провайдеров в сервера DNS.

далее в Scripts добавляется скрипт

#set variables
:local PingCount 3
 
# www.ya.ru
:local IPToPing 77.88.21.3
:local IpOMKC [/ip address get [/ip address find interface=omkc_pppoe] address]
:local IpEnforta [/ip address get [/ip address find interface=enforta] address]
:local pingresultA [/ping $IPToPing count=$PingCount src-address=$IpOMKC]
:local pingresultB [/ping $IPToPing count=$PingCount src-address=$IpEnforta]

#if link_OMKC is DOWN and link_Enforta is UP then:
:if (($pingresultA=0) && ($pingresultB=$PingCount)) do={
 
:if ((([/ip route get [find comment="Enforta"] distance]=1)&&([/ip route get [find comment="OMKC"] distance]=2))=false) do={
:log warning "set routes to Enforta"
/ip route set [find comment="Enforta"] distance=1
/ip route set [find comment="OMKC"] distance=2
}
}

#if link_OMKC is UP and link_Enforta is DOWN then:
:if (($pingresultA=$PingCount) && ($pingresultB=0)) do={ 
:if ((([/ip route get [find comment="OMKC"] distance]=1)&&([/ip route get [find comment="Enforta"] distance]=2))=false) do={
:log warning "set routes to OMKC"
/ip route set [find comment="OMKC"] distance=1
/ip route set [find comment="Enforta"] distance=2
}
}

#if both link's are UP then:
:if (($pingresultA=$PingCount) && ($pingresultB=$PingCount)) do={
 
:if ((([/ip route get [find comment="OMKC"] distance]=1)&&([/ip route get [find comment="Enforta"] distance]=2))=false) do={
:log warning "both link's are UP, default gateway is OMKC"
/ip route set [find comment="OMKC"] distance=1
/ip route set [find comment="Enforta"] distance=2
}
}

где omkc_pppoe - название pppoe соединения к OMKC, Enforta - коммент к роуту для Энфорты, OMKC - коммент к роуту для ОМКС.
необходимо учесть, что скрипт работает по комментариям к роутам ( .....[/ip route get [find comment="OMKC"] .....-ищет роут с комментом OMKC).

далее в Scheduler добавляется name=InternetTest OnEvent=InternetTest, policy указать все, interval 30 секунд.

проверка интернета на mikrotik

Phantom пишет

mikrotik
второй ethernet порт выгорел от грозы.
IP ethernet порта 1 : 192.168.1.5
IP ethernet порта 4 : 192.168.4.1
IP адрес на 3 порту (куда вставляетс кабель ОКС) не нужен
ethernet порт 1 используется для подключения к локальной сети
ethernet порт 3 используется для подключения кабеля ОКС
для того, чтобы проверить работоспособность mikrotik, необходимо подключиться с rs1i через утилиту winbox на IP порта микротика (на rs1i IP на сетевой карте WAN_1 192.168.1.6) или через интернет на адрес reaktor.ddns.info
логин: phantom, пароль puer8
слева в списке выбираем "Log", если бесконечно появляются надписи

Jan/10/1970/ 12:12:12 pppoe ppp info pppoe-out1 dialing....
Jan/10/1970/ 12:12:12 pppoe ppp info pppoe-out1 terminating...-disconnected
Jan/10/1970/ 12:12:12 pppoe ppp info pppoe-out1 disconnected
Jan/10/1970/ 12:12:12 pppoe ppp info pppoe-out1 initializing....

это значит, что микротик не может подключиться по pppoe соединению
значит проверяем wi-fi точки доступа
чтобы сменить логин или пароль для подключения к интернет, необходимо подключиться к микротику через winbox
выбрать из списка "PPP", вкладка Interfaces -> 2 раза на pppoe-out1, вкладка "Dial-out"
там и будет логин-пароль для подключения к интернет
во вкладке "General" можно поменять интерфейс, к которому подключен интернет
IP не обязательно на этом порту, но и убирать его специально необязательно

Редактировался viktor (06.12.2011, 22:52:13)

 

Дизайн сайта отсутствует
оформление: Группа «САМОВАРчик»

[ Сгенерировано за 0.015 сек, 8 запросов выполнено - Использовано памяти: 1.9 MiB (Пик: 1.96 MiB) ]